Installing Zend Optimizer

Notice

This tutorial is for older Debian versions and may not work for current versions. Please refer to the links below to find a newer tutorial.

The Zend Optimizer enables you to run Zend Guard encoded files.

1. Download a copy of Zend Optimizer / Guard from the location below and put it into /tmp

http://www.zend.com/en/products/guard/downloads

2. Extract

cd /tmp
tar zxvf ZendOptimizer-3.3.9-linux-glibc23-i386.tar.gz

Replace with your actual filename

3. Create a directory to contain Zend optimizer

mkdir /usr/local/lib/Zend

3. Move the Zend optimizer lib to a permanent location

mv ZendOptimizer-3.3.9-linux-glibc23-i386/data/5_2_x_comp/ZendOptimizer.so /usr/local/lib/Zend/

Your ZendOptimizer directory name may be different since it includes version numbers and platform. I’m using the 5_2_x_comp directory because I have PHP 5.2 installed.

4. Add reference to your php.ini file (pico /etc/php5/apache2/php.ini)

zend_extension = /usr/local/lib/Zend/ZendOptimizer.so
zend_optimizer.optimization_level = 15

5. Restart apache

/etc/init.d/apache2 restart

18 comments

  1. Thanks for the great instructions for installing Zend. The (tiny) stumbling point was that there is no specific section for the references in php.ini… they can go anywhere I think!

  2. Thanks for this tutorial, but it doesn’t work on my Debian server (64bit). I followed the 5 steps as described, but I get an “exit signal Segmentation fault (11)” in the apache log after restart.

    No other modules are installed. APC is running though.

    Any idea?

  3. Excellent little tutorial — much improved over the “manual” provided on the Zend site (which is outdated and inaccurate, to my eye).

    Thanks a bunch!

  4. THANK YOU!
    problem solved. the problem as that my downloaded version from zend did not contain the 5.2-version. i do not know why. i was am verzweifeln, but your tut did it! THANX!

  5. I followed so many isntructions I did exactly as you’ve said and I still cannot get it to work.
    I have a script which tells me I need zend opimizer v.3.0.0 or higher.

    phpinfo (); shows
    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans

    As you can see, it still shows version 2.3.0 — I have no idea where it is
    showing this and how to get rid of it? How do I fix this…

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>